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Date Nov 15, 19
SIMCA®-online 15.1
SIMCA®-online 15
SIMCA®-online 14
Problem

SIMCA®-online service fails to stop completely causing data for active batches to be lost (Q928)

Symptoms:

The following can happen on SIMCA®-online servers with heavy load and many executing configurations:

  • SIMCA®-online 15.1*: Reset alarms or notes for active batches are lost following a restart of the SIMCA®-online service.
  • SIMCA®-online 15.1*: Batches that were active when the service was stopped, are not suspended (keeping all data so that they can be resumed).
  • Server audit trail displays the entry unexpected Shutdown when the service has been started again.
  • The server log does not show the "Logfile closed" entry which would indicate a successful stop of the service.

*) SIMCA®-online 15.1 was the first version that keeps data for active batches when the service is stopped so that old data need not be re-read and reset alarms are kept. In earlier versions, active batches including all data are always deleted. When the service is started, active batches are then re-read from the beginning. This means that the behavior of SIMCA®-online 15.1 here reverts to the behavior of the earlier versions.

This does not happen on all SIMCA®-online servers. The likelihood increases on servers that have many executing configurations, have a slow data source, or are otherwise slow.

There is no data lost with the above exceptions for SIMCA®-online 15.1. When the service is started again, active batches are caught up automatically and new alarms triggered.

Cause:

The server fails to stop threads in the correct order, resulting in the service being stopped by Windows before all subsystems, including the ones that suspends active batches, have stopped.

Workaround:

  • Stop execution for unneeded project configurations to decrease the general load of the server.
  • If you know that you must restart the service, you can manually stop execution for project configurations before stopping the service, and restart them when the service has been restarted again.

This should make the service stop quicker, resulting in that it will have time to finish before it is terminated by Windows.

Status:

This issue is fixed in SIMCA®-online 16.0.

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