SIMCA-online® 17 long server startup time and slow starting or stopping execution
Symptoms
It takes a long time to start the server service before clients can log in.
This affects SIMCA-online 17.0, 17.0.1 and 17.0.2.
More information
The server logs show that all SimApis have been initialized completely and that some project configurations are executed, but it takes a long time before ALL project configurations have started, and the server can accept client logins.
Similar problems can be seen when manually starting or stopping execution for many project configurations while the server is running.
The likelihood for having issues like this increases with the number of executing project configurations on the server with the same execution interval, a short execution interval, and in combination with a data source that is relatively slow to respond for requests for data.
Internal bug number: 45990
Fix
Fixed in SIMCA-online 17.0.3.
This version speeds up starting of project executions at startup. It does not improve startup times of SimApis that are slow to initialize. Such problems are usually caused by a slow network between SIMCA-online server and the data source, or simply by many data source tags that need to be enumerated at startup.
Workaround
If possible, reduce the number of executing project configurations.
With some data sources and SimApi, such as relational databases, views and tables can be optimized and indexed to reduce query times.
Cause
The server is sensitive to slow data sources. During read operations, the server cannot add or remove executing project configurations, without having to wait until current read-operations complete.